MikroTikルータ―はScriptが使えます。
そのため、色々なスクリプトを書くことが可能です。
今回は、Scriptとルータ―ならではの機能を使ってYouTubeの制限をかけたいと思います。
簡単なWi-Fiの利用不可制限やドメインのブロックなどは、他のルータ―でも機能としてあると思いますが、
今回やるのは、YouTubeを1日110MB以上見たら、YouTubeをブロックです。
子供のYouTubeの見過ぎ等困ったことありますよね。YouTubeがいけないとは言いませんが…
設定は以下のコードをルーターに入れるだけで基本的にはOKです。1分おきに容量を監視して、110MB以上になったら、YouTubeをブロックします。容量監視は0時の段階で、リセットされます。(YouTubeも見れるようになります。
これを応用すれば色々できそうですね…
コードは以下の通りです。
/ip firewall layer7-protocol
add name=youtube regexp="^.+(youtube.com|googlevideo.com).*\\\$"
/ip firewall filter
add action=accept chain=forward comment=youtube_ok layer7-protocol=youtube \
protocol=tcp
add action=drop chain=forward layer7-protocol=youtube protocol=tcp
/system scheduler
add interval=1d name=schedule1 on-event="/ip firewall filter set [find comment\
=\"youtube_ok\"] disabled=no\r\
\n/ip firewall filter reset-counters [find comment=\"youtube_ok\"]\r\
\n" policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-date=may/09/2022 start-time=00:00:00
add interval=1m name=schedule2 on-event=check_youtube policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
start-time=startup
/system script
add name=check_youtube owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":\
local youtube [/ip firewall filter get [/ip firewall filter find comment=\
\"youtube_ok\"] bytes];\r\
\n\r\
\n:if (\$youtube > 110000000) do={\r\
\n/ip firewall filter set [find comment=\"youtube_ok\"] disabled=yes\r\
\n:log warning \$youtube;\r\
\n}\r\
\n\r\
\n\r\
\n"
#MikroTik RouterBOARD hEX(RB750Gr3) #YouTubeブロック #youtube 容量監視 #Viewing capacity monitoring #YouTube block
hEX RB750Gr3のご購入は是非、当ショップページまたは「街のルータ―屋さんAmazon店」からお願いします。
ご購入いただいた方へはサポートをさせていただきます!!
よろしくお願いいたします。